With CVE-2014-8730 the POODLE attack is back. However with the right config it is not an issue.  https://mariobrandt.de/archives/apache/current-2013-bullet-proof-ssl-config-779/ is still the right config for this :) Make sure that your server is bullet proof, too.